当前位置:  首页  >  服务器技术  >  Linux/unix  >  Linux系统

Ubuntu10.04源码编译安装bochs2.4.5

成功在Ubuntu10.04下源码编译安装bochs2.4.5,主要是在配置Bochs的过程中出现了太多错误了。如果出现1、checkingforCcompilerdefaultoutputfilename…configure:error:Ccompilercannotcreateexecutables解决方法:apt-getinstalllib

成功在Ubuntu 10.04下源码编译安装bochs 2.4.5,主要是在配置Bochs的过程中出现了太多错误了。

如果出现

1、checking for C compiler default output file name… configure: error: C compiler cannot create executables

解决方法: apt-get install libc6-dev

2、configure: error: C++ preprocessor "/lib/cpp" fails sanity check

解决方法:apt-get install build-essential

3、X windows gui was selected, but X windows libraries were not found.

解决方法:参照04年课程论坛上的解决方法,配置的时候加上--with-nogui(不过后来试了,改成apt-get install xorg-dev也行 )

4、make: ***[install_bin] 错误 1

解决方法:其实很简单,在命令前加上sudo就行,就是sudo make install

-------------------------分割线-------------------------

首先得到 bochs-2.4.5.tar.gz 安装包,同样可以从 www.bochs.sourceforget.net 上得到。

1. sudo apt-get install build-essential

2. sudo aptitude install xorg-dev

3. sudo aptitude install libgtk2.0-dev

4. tar vxzf bochs-2.4.5.tar.gz

5. cd bochs-2.4.5/

6. ./configure --enable-debugger --enable-disasm

7. make

8. make install

吐了个 "CAO" !
扫码关注 PHP1 官方微信号
PHP1.CN | 中国最专业的PHP中文社区 | 凯发国际娱乐 | 凯发国际娱乐下载 | 数据库技术 | 服务器技术 | 前端开发技术 | PHP框架 | 开发工具 | PHP问答
Copyright © 1998 - 2020 PHP1.CN. All Rights Reserved PHP1.CN 第一PHP社区 版权所有