当前位置:  首页  >  服务器技术  >  Linux/unix  >  Linux入门

64位linux下安装eva的问题

64位linux下安装eva的问题--Linux通用技术-Linux技术与应用信息,下面是详情阅读。
原创:三翻领

EVA-0.4.1(下同),应该说是linux下迄今最好的QQ兼容客户端了吧。早期有luma独自开发的lumaqq可谓一统天下,其特有的“如来神掌”更是使其名声大振。但是毕竟lumaqq基于java,速度比较慢,而且许多有用的功能无法实现,比如传送文件、抓图等(腾讯的许多垃圾功能不要也罢)。此时,老云的EVA横空出世。EVA基于QT,依赖kdelibs(几乎也就是依赖kde了——千里姑娘云),虽然运行环境还是有很大的局限性,比如肯定不能想lumaqq一样运行于windows系统,gnome用户为解决依赖问题而要安装不少kde的包,但是从功能上讲,EVA无疑是linux下QQ兼容客户端的最佳方案。她除了最基本的聊天功能(包括群)外,还支持传送文件、抓图、自定义表情、快捷键、字体自定义等高级功能。

本人不懂编程,但是很有幸由于系统arch问题曾经帮助EVA作者云帆做过测试,并顺利解决当初版本在64位系统下运行崩溃问题,也算为开源事业做过贡献吧[wink]

切入正题,32位环境编译EVA很简单,在源码包里面有说明,但是对于64位系统的话,就不那么简单了,如果用默认的编译参数去编译话,很有可能会找不到一些库和QT而导致./configure失败,所以就要调整编译参数,具体如下:

./configure --with-qt-dir=/usr/lib/qt3 --with-qt-includes=/usr/lib/qt3/include --with-qt-libs=/usr/lib/qt3/lib64 --enable-libsuffix=64 --prefix=`kde-config --prefix`

此方法在suse-10.0、suse10.1的64位系统下测试通过,其他64位发行版如果在编译EVA的时候./configure出错,可以参考尝试。
吐了个 "CAO" !
扫码关注 PHP1 官方微信号
PHP1.CN | 中国最专业的PHP中文社区 | 凯发国际娱乐 | 凯发国际娱乐下载 | 数据库技术 | 服务器技术 | 前端开发技术 | PHP框架 | 开发工具 | PHP问答
Copyright © 1998 - 2020 PHP1.CN. All Rights Reserved PHP1.CN 第一PHP社区 版权所有